UCS Security - Self Service for Your Account

System Requirements

Index

  1. Accessibility Standards and Guidelines
  2. Supported Browsers

Accessibility Standards and Guidelines

Standards

We are striving to be compliant with the following standards:

Guidelines

We keep the following guidelines in mind when designing, developing, and testing our pages:

Back to Index

Supported Browsers

In order to access UCS web-based applications, you should use a supported web browser. UCS tests to ensure full functionality on the latest versions of the following browsers and platforms. The versions listed indicate absolute minimum versions. Versions older than these have known incompatibilities and will not function for accessing UCS systems.

Whenever possible, you are encouraged to run the latest version of the browser and operating system for your platform. Older versions contain security vulnerabilities which may lead to compromise of your data or privacy.

If you are using a browser not listed below and encounter trouble accessing applications, please try one of the listed browsers before reporting problems. While other browsers and platforms may work for some applications, UCS is unable to provide support for any issues which may arise on non-supported systems. Certain UCS applications may have specific requirements which differ from what is listed below. These applications list their specific requirements in their documentation, about, or "FAQ" sections.

Desktop Browsers

Browser Version Released Windows macOS Linux
Google Chrome 38+ July 2014 Yes Yes Yes
Mozilla Firefox 31+ Sept 2014 Yes Yes Yes
Apple Safari 7+ Oct 2013 Yes Yes
macOS 10.9+
No
Microsoft Edge 20+ July 2015 Yes No No
Internet Explorer 11+ Oct 2013 Yes No No
IE 8+ may be sufficient on Windows 7+, provided TLS 1.2 support is manually enabled.

Mobile Browsers

Browser Version Released iOS Android
Google Chrome 38+ July 2014 Yes Yes
4.0.3+
Mozilla Firefox 31+ Sept 2014 Yes Yes
Apple Safari 5+ Oct 2011 Yes
iOS 5+
No

Windows 7, 8, and 10 are supported.

macOS Mavericks (10.9) and newer are supported.

Linux support is limited and OS-level support for Linux cannot be provided.

Back to Index

Self Service Password Reset